Usas un child theme? Cuidado con wordpress 3.1

El dia que les comente las novedades de wordpress 3.1 tambien les dije que tuvieran cuidado con esta pues estaba planeado que tambien se actualizara el theme twenty ten a su version 1.2 y asi lo hizo.

Cual es el inconveniente? Que la mayoria tuneamos nuestros themes a nuestro gusto y aquellos que hayan estado usando y modificando el theme twenty ten perderan todos los cambios.

Como se soluciona? No hay una solucion simple, lo mejor era tener un child theme y realizar las modificaciones alli. Pero alli tambien surge otro problema, algunos child themes no solo modifican el archivo style.css y functions.php sino que hacen sus propias versiones de otros archivos como index.php, header.php, etc. Y puede que en esos archivos hayan usado funciones viejas que ya no sirven en wordpress, generando con esto la descomposicion de algunos childs themes.

Lo mejor para los amantes de twenty ten es usar un theme que no modifique nada mas que style.css y funcions.php. Por ejemplo el child theme ParaisoLinux que cree hace un tiempo y que es el mismo que estoy usando.

Por cierto, pronto sacare una actualizacion de dicho child theme de twenty ten.

perro

Ingeniero en Informática. Programador en PHP y Angular. Lo que mas adoro en el mundo es el conocimiento. Y el anime....y Japón...y el running...y bloguear claro y algunas otras cientos de cosas. Sigo buscando la manera de hacer mi primer millón.

Comenta!

avatar