PSeInt – Pseudocodigo para no programadores

Son muchas las carreras no informaticas en las que en algun momento enseñan logica de programacion utilizando diagramas de flujo y pseudocodigo. Lo dificil es enseñar a probar esos codigos en algun lenguaje de programacion porque habria que enseñar lo basico de ese lenguaje. Pero PSeInt nos sirve para evitar tener que aprender un lenguaje y quedarnos solo con los diagramas y escribir un pseudocodigo que realmente podamos probar.

La idea basica es escribir codigo en español y lograr ver un resultado ejecutable.

Ej:  El siguiente codigo calcula el promedio de una lista de datos.

// Calcula el promedio de una lista de N datos
Proceso Promedio
          Escribir "Ingrese la cantidad de datos:";
          Leer n;

          acum<-0;

          Para i<-1 Hasta n Hacer
                    Escribir "Ingrese el dato ",i,":";
                    Leer dato;
                    acum<-acum+dato;
          FinPara

          prom<-acum/n;
          Escribir "El promedio es: ",prom;
FinProceso

Como veran los comandos que se usan son «Leer», «Para», «Escribir», y tambien existen otros como el clasico «Si-Sino-Entonces». Codigo realmente facil de entender. Y seguro algunos programadores van a decir: ‘deberian enseñar directamente usando un lenguaje real’, pero estoy seguro que entonces nunca se han topado con medicos, contadores, etc que no saben nada de nada de pcs. Esto SI ayuda mucho.

La ejecucion del programa se muestra en una consola que el mismo programa abre. Algo asi:

Pseint ejecucion

El programa tambien sirve para enseñar mediante diagramas de flujo. Es decir que se pueden crear y editar bloques y asi crear el pseudocodigo y ejecutar el programa.

Diagramas de flujo pseint

El programa cuenta con mucha documentacion integrada y codigos de errores claros y entendibles por cualquiera. Todo en español por supuesto. En la web tambien hay mas documentacion, codigos de ejemplos y videos para entender el programa.

Como instalar pseint?

En la pagina oficina estan las opciones de descarga para windows, linux y mac os. Como nosotros usamos linux lo que vamos a hacer es elegir la version (32 o 64 bits), descomprimir el paquete y luego le dan doble click al archivo llamado wxPSeInt.

Esto no lo instala sino que lo ejecuta directamente.

Espero que les sirva, en especial a los profesores de algunas carreras universitarias

Web oficial: pseint.sourceforge.net

perro

Ingeniero en Informática. Programador en PHP y Angular. Lo que mas adoro en el mundo es el conocimiento. Y el anime....y Japón...y el running...y bloguear claro y algunas otras cientos de cosas. Sigo buscando la manera de hacer mi primer millón.

11
Comenta!

avatar
Noir
Noir

la verdad es de gran ayuda para comenzar a programar sobre todo porque te das una clara idea si no dominas el ingles

CescQuintero
CescQuintero

Wow… pensar que esta era un idea que tenía con un compañero… es magnifica!

chris
chris

gracias realmente buscaba algo asi, me sirvio bastante.

Jhonatan Martinez
Jhonatan Martinez

Te debo dar las gracias una y mil veces no sabes lo beneficioso que ha de ser este programa para mi, y lo he de compartir con mis compañeros y mi profesora de lógica de programación, realmente me es muy útil ya que apenas comienzo a «sumergirme» en este mundo de la programación.
Muchísimas gracias

sefsinalas

Que bueno que sea de utilidad :)

Bianca
Bianca

Intenté instalarlo en una tablet y no funciona. Descargué el paquete para linux y realicé los pasos que menciona la pagina sin resultado. Podrán ayudarme?

Alejandro Caro
Alejandro Caro

Bájate e instala la versión para android de PseInt Pseudocode, PSeInt Algoritmos que se baja desde google play

luis angel HM
luis angel HM

ya me salio :)

escribir «Ingrese la cantidad de datos del 1 – 100:»;
Leer n;

d<-20

acum<-0;

Para i30 entonces
escribir «es mayor al numero»
sino
escribir «es menor al dato»
FinSi
si dato=30 entonces
escribir » muy bien felicidades es 20″
n=0
FinSi
acum<-acum+dato;
FinPara

Escribir "winners san juan: "

FinProceso
lima – peru

victoria
victoria

hola como estas necesito ayuda con un algoritmo en pseint… te agradecería me guíes como encararlo ahí va: realizar un algoritmo que calcule el precio del mantenimiento programado o service oficial de un vehículo volkswagen. teniendo en cuenta las siguientes consideraciones: kilometraje del vehiculo si es nafstero: cada 15.000 km o 1 año, lo primero que se cumpla si es diesel: cada 7.500km o 1 año lo primero que se cumpla si es un amarok: cadsa 10.000km o 1 año lo primero que se cumpla. también ubicación geográfica donde se realiza el mantenimiento: capital y gba interior, cuyo, litoral, centro… Leer mas »

Jocsan
Jocsan

Buenas Necesito ayuda con un pseudocodigo que permita ingresar 10 articulos a una canasta ,escribir cada articulo en pantalla .Al terminar escribir canasta llena.ESTRUCTURA DE REPETICION MIENTRAS