Instalar virtualbox 2.2-2 en Ubuntu Jaunty

  • Categoría de la entrada:Aplicaciones

Con el fin de realizar algunas tareas sobre un sistema GNU/Linux que use el entorno KDE he tenido que instalar en una maquina virtual un Linux con KDE, habia pensado en instalar fedora pero al final me decidi por Kubuntu. Pero lo importante es que al intentar instalar VirtualBox desde el synaptic me doy con que la ultima version en los repositorios es las 2.1 por eso busque en internet y en el blog de rm -rf encontre la solucion para instalar la ultima version de VirtualBox usando los repositorios.

Solo deben seguir estos pasos:

En una consola escriben:

sudo gedit /etc/apt/sources.list

Al final del archivo que se les abrira escriben

deb http://download.virtualbox.org/virtualbox/debian jaunty non-free

Obtenemos la clave asi:

wget -q http://download.virtualbox.org/virtualbox/debian/sun_vbox.asc -O- | sudo apt-key add –

Guardan y cierran el archivo. Ahora actualizamos los repositorios como ya todos sabemos:

sudo apt-get update

Y para la instalacion simplemente tecleamos en una consola lo siguiente:

sudo apt-get install virtualbox-2.2

Y listo!

perro

Ingeniero en Informática. Programador en PHP y Angular. Lo que mas adoro en el mundo es el conocimiento. Y el anime....y Japón...y el running...y bloguear claro y algunas otras cientos de cosas. Sigo buscando la manera de hacer mi primer millón.
guest
9 Comments
Inline Feedbacks
View all comments
Santiago

Hola, muchas gracias por tu post. ¿tenés idea de por qué me aparece este mensaje?

W: Error de GPG: http://download.virtualbox.org jaunty Release Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY DCF9F87B6DFBCBAE
W: Tal vez quiera ejecutar ‘apt-get update’ para corregir estos problemas

Muchas gracias.

Calixto

Eso es porque no has agregado la PUBLIC KEY, para esto ejecuta lo que se especifica arriba

wget -q http://download.virtualbox.org/virtualbox/debian/sun_vbox.asc -O- | sudo apt-key add –

DuKKoN

Te falto añadir un usuario al grupo que se crea durante la instalación. Solo los usuarios pertenecientes al grupo ‘vboxusers’ tienen pleno control del nuevo virtualbox:

‘sudo gpasswd -a dukkon vboxusers’

Sin las comillas y cambiando dukkon por tu usuario de sistema…

Un Saludo!

Jose Vasquez

Hola,
estoy tratando de instalar el Virtualbox segun explicas, pero me sale el siguiente mensaje :
virtualbox-2.2: Depends: libpython2.6 (>= 2.6) but it is not installable
Depends: libqt4-network (>= 4.5.0~+rc1) but it is not going to be installed
Depends: libqtcore4 (>= 4.5.0~+rc1) but it is not going to be installed
Depends: libqtgui4 (>= 4.5.0~+rc1) but it is not going to be installed
E: Broken packages

saludos

Tiolucas

Muchas gracias Sr. Can, funcionó perfecto para actualizar VirtualBox 3.0.0 a 3.0.12 en Ubuntu 9.04.

Lo mismo se puede hacer para actualizar Opera (mi navegador favorito) a la versión 10.10 que está terrible bastante mejor que Firefox, Chrome, Explorer, etc.

Gustavo

Hola Perro
La consulta es: para instalar virtualbox en ubuntu lucid ¿hay que cambiar algo en el código que ponés en la consola? lo pregunto porque este tuto es para jaunty y supongo que en algo diferirá. Aguante perro :up: